Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[3.1] Won't send attachments/display new pictures

edited November 2014 in Bug Reports
Just bought your tweak and having some problems with it.
I'm on iPhone 6+ iOS 8.1
So as title states remote messages won't send attachments of any kind and will not display new pictures only the ones that were sent/received before remote messages was open in browser.


  • edited November 2014
    +1 on Attachments not working - although they appear to be sent in RM none can be found when opening messages on the phone

    - Haven't tested pictures
  • What sort of attachments aren't working? Images/Movies/Audio?
  • Didn't I say "any".?
    Whatever attachment I want to send it doesn't do anything when I clikc on send.
    I've been trying photos/videos.
    My friend with iOS 7 can send anything and it works even .exe files.
  • I tried to attach a .jpg from my computer too - didn't work
  • @Kasper when you attach an image to a message from your computer do you get a preview of it sending in your chat transcript? Does it ever work or does it consistently fail? Are these messages iMessages or MMS?
  • edited November 2014
    Nope, i'm attaching the png file - press send then a paperclip appears in the chat history.

    No image is received by the recepient - tested both iMessage and MMS.
    Nor is any message (or image) sent when looking at the conversation on the iphone.

    Using Chrome for PC, iPhone 6 with iOS 8
    Also a problem in Firefox - Additionally, the paperclip disappears when you reload the page.
    Error is consistent.

    Maybe i'm missing a depency for transfering the file to my phone?
  • Also unable to receive attachments/pictures.

    Notification says [Attachment], but picture is not shown - refreshing the browser does not help.
  • I've managed to make mine fail to send attachments now, it just hangs on a transparent paperclip bubble.

    I am able to send images using the camera icon (camera roll attachment), is that working for you?

    I am also able to receive images still.
  • AlAl
    edited November 2014
    Try executing the following commands over SSH as root:

    chown -R mobile /private/var/mobile/Library/RemoteMessages/

    This should fix quite a few issues ._.
    Could you guys please confirm which issues have since been resolved after running these?
  • Thanks Al that did fix the problem with attachments but new pictures still don't show up in remote messages until I disable and re-enable it.
  • Can you try and save the thumbnail, you may have to use the inspector tool in Chrome (F12)

    I need to know if the thumbnail/preview being sent from the RM server is *actually* 1x1
  • no thumbnail is displayed unless i disable re-enable remote messages.

    have a look at the printscreen
  • edited November 2014
    Changing the owner to mobile solved the attachment issue!

    Images are still not showing up, the thumbnail is the problem, the image reference itself works if you access it directly via /media/%2B4553833949/p:0/AE5088A9-004A-4106-A6E6-42E304486309/IMG_0257.JPG.

    (<)a class="fancyboxed" href="/media/%2B4553833949/p:0/AE5088A9-004A-4106-A6E6-42E304486309/IMG_0257.JPG" target="_blank">
    (<)img src="/media-preview/%2B4553833949/p:0/AE5088A9-004A-4106-A6E6-42E304486309">

    It appears that the thumbnail document is generated while its resource isn't.

    Source of /media-preview/%2B4553833949/p:0/05B06017-CEC9-4847-B4C9-1084F9E19CE6
    (<)html>(<)head>(<)meta name="viewport" content="width=device-width, minimum-scale=0.1">(<)title>05B06017-CEC9-4847-B4C9-1084F9E19CE6 (1×1)(<)/title>(<)/head>(<)body style="margin: 0px;">(<)img style="-webkit-user-select: none" src="http://kaspers-iphone.local:333/media-preview/+4553833949/p:0/05B06017-CEC9-4847-B4C9-1084F9E19CE6">(<)/body>(<)/html>

    Thumbnail appears as a 1x1px black element in the conversation.
    See screenshot:
  • AlAl
    edited November 2014
    What do you see when you request the media-preview:
    e.g. http://kaspers-iphone.local:333/media-preview/+4553833949/p:0/05B06017-CEC9-4847-B4C9-1084F9E19CE6
    (obviously this will work now since you've restarted RM, but if you could reproduce a problem image with another url...)
  • Are the images being sent from another Remote Messages device, stock iOS device or Mac?
  • edited November 2014

    I already showed you the sourcecode of the media-preview request.
    - Not sure what else you want, well I see nothing but a blank page when i run the request :-)

    Android (mms)
    Tested incoming picture - not working.
    Outgoing attachment from browser (picture) - not working.
    Outgoing attachment from iPhone (picture - not working.

    iPhone (iMessage)
    Tested incoming picture - not working.
    Outgoing attachment from browser (picture) - not working.
    Outgoing attachment from iPhone (picture - WORKS!

    Sending from iMessage to myself, through either browser or phone also works.

    Also noticed an issue when attempting to open a conversation with an sms having a subject field - crashing RM.
Sign In or Register to comment.